summaryrefslogtreecommitdiffstats
path: root/doc/posix1003.1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/posix1003.1/Makefile.am')
-rw-r--r--doc/posix1003.1/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/doc/posix1003.1/Makefile.am b/doc/posix1003.1/Makefile.am
index cceafb6dfe..f36a0af20c 100644
--- a/doc/posix1003.1/Makefile.am
+++ b/doc/posix1003.1/Makefile.am
@@ -18,7 +18,8 @@ GENERATED_FILES = ch01.texi ch02.texi ch03.texi ch04.texi ch05.texi \
ch13.texi ch14.texi ch15.texi ch16.texi ch17.texi ch18.texi ch19.t \
ch19.texi
-COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi \
+ $(top_srcdir)/common/cpright.texi
FILES = preface.texi
@@ -115,10 +116,10 @@ $(srcdir)/ch18.texi: ch18.t
-u "Top" \
-n "Compliance Summary" < $< > $@
-ch19.t: ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t ch09.t \
- ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t \
+$(srcdir)/ch19.t: ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t \
+ ch09.t ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t \
summarize
- ./summarize >ch19.t
+ (cd $(srcdir) && ./summarize > $@)
$(srcdir)/ch19.texi: ch19.t
$(BMENU2) -c -p "List of Cancellation Points" \
@@ -127,4 +128,6 @@ $(srcdir)/ch19.texi: ch19.t
noinst_SCRIPTS = summarize
-EXTRA_DIST = *.t compliance_list summarize
+EXTRA_DIST = ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t ch09.t \
+ ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t ch19.t \
+ compliance_list summarize