summaryrefslogtreecommitdiffstats
path: root/doc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'doc/configure.in')
-rw-r--r--doc/configure.in152
1 files changed, 152 insertions, 0 deletions
diff --git a/doc/configure.in b/doc/configure.in
new file mode 100644
index 0000000000..adc4f15c81
--- /dev/null
+++ b/doc/configure.in
@@ -0,0 +1,152 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.13)
+
+AC_INIT(project.am)
+
+AM_INIT_AUTOMAKE(rtemsdoc,4.5.0-beta2,no)
+
+RTEMS_VERSION="$VERSION"
+AC_SUBST(RTEMS_VERSION)
+
+RTEMS_RELEASE="4.5.0"
+AC_SUBST(RTEMS_RELEASE)
+
+AC_ARG_ENABLE(html,
+[ --disable-html disable html support ],
+[case $enableval in
+yes) ;;
+no) ;;
+*) AC_MSG_ERROR("invalid value");;
+esac],
+[enable_html="yes"]
+)
+
+AC_ARG_ENABLE(dvi,
+[ --disable-dvi disable dvi support ],
+[case $enableval in
+yes) ;;
+no) ;;
+*) AC_MSG_ERROR("invalid value");;
+esac],
+[enable_dvi="yes"]
+)
+
+AC_ARG_ENABLE(pdf,
+[ --disable-pdf disable pdf support ],
+[case $enableval in
+yes) ;;
+no) ;;
+*) AC_MSG_ERROR("invalid value");;
+esac],
+[enable_pdf="yes"]
+)
+
+AC_ARG_ENABLE(ps,
+[ --disable-ps disable ps support ],
+[case $enableval in
+yes) ;;
+no) ;;
+*) AC_MSG_ERROR("invalid value");;
+esac],
+[enable_ps="yes"]
+)
+
+htmldir='$(pkgdatadir)/html'
+AC_SUBST(htmldir)
+
+dnl Checks for programs.
+AC_PROG_LN_S
+
+AC_CHECK_PROGS(PERL,perl)
+
+TEXI2WWW='$(PERL) $(top_srcdir)/tools/texi2www/texi2www'
+AC_SUBST(TEXI2WWW)
+
+AC_CHECK_PROGS(GS,gs)
+AM_CONDITIONAL(GS,test x"$GS" != x"")
+
+# TEXI2DVI='$(PERL) $(top_srcdir)/tools/texi2www/texi2dvi'
+AC_CHECK_PROGS(TEXI2DVI,texi2dvi)
+AM_CONDITIONAL(TEXI2DVI,test x"$TEXI2DVI" != x"")
+
+if test "$enable_pdf" = "yes"; then
+ AC_CHECK_PROGS(EPSTOPDF,epstopdf)
+ AM_CONDITIONAL(EPSTOPDF,test x"$EPSTOPDF" != x"")
+
+ AC_CHECK_PROGS(TEXI2PDF,texi2pdf)
+ AM_CONDITIONAL(TEXI2PDF,test x"$TEXI2PDF" != x"")
+fi
+
+AM_CONDITIONAL(USE_HTML,
+ test "$enable_html" = "yes" \
+ && test x"PERL" != x"" )
+
+AM_CONDITIONAL(USE_DVI,
+ test "$enable_dvi" = "yes" \
+ && test x"$TEXI2DVI" != x"" )
+
+AM_CONDITIONAL(USE_PS,
+ test "$enable_ps" = "yes" \
+ && test x"$TEXI2DVI" != x"" )
+
+AM_CONDITIONAL(USE_PDF,
+ test "$enable_pdf" = "yes" \
+ && test x"$TEXI2DVI" != x"" \
+ && test x"$TEXI2PDF" != x"" )
+
+AM_CONDITIONAL(USE_EXP, test x=y )
+
+BMENU='$(top_builddir)/tools/bmenu/bmenu'
+AC_SUBST(BMENU)
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+
+dnl Checks for library functions.
+
+AC_CONFIG_SUBDIRS(tools)
+
+AC_OUTPUT(
+Makefile
+rtems_header.html
+rtems_footer.html
+rtems_support.html
+index.html
+images/Makefile
+common/Makefile
+common/setup.texi
+FAQ/Makefile
+develenv/Makefile
+user/Makefile
+bsp_howto/Makefile
+started/Makefile
+started/pictures/Makefile
+porting/Makefile
+networking/Makefile
+posix_users/Makefile
+posix1003.1/Makefile
+filesystem/Makefile
+itron3.0/Makefile
+ada_user/Makefile
+started_ada/Makefile
+rtems_gdb/Makefile
+rgdb_specs/Makefile
+relnotes/Makefile
+new_chapters/Makefile
+supplements/Makefile
+supplements/hppa1_1/Makefile
+supplements/i386/Makefile
+supplements/i960/Makefile
+supplements/m68k/Makefile
+supplements/mips64orion/Makefile
+supplements/powerpc/Makefile
+supplements/sh/Makefile
+supplements/sparc/Makefile
+supplements/template/Makefile
+gnu_docs/Makefile
+src2html/Makefile
+)