summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 3e90933fba..cb50680bac 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -7,7 +7,7 @@ ACLOCAL_AMFLAGS = -I ../aclocal
# NOTE: The order of the directories is essential.
# + tools, common and images are shared across many documents
-SUBDIRS = tools common images FAQ started user bsp_howto porting develenv \
+SUBDIRS = tools FAQ started user bsp_howto porting develenv \
posix_users posix1003.1 filesystem itron3.0 networking ada_user \
started_ada rtems_gdb rgdb_specs new_chapters relnotes supplements \
gnu_docs src2html
@@ -21,3 +21,16 @@ AUTOMAKE_FILES = project.am main.am
EXTRA_DIST = $(AUTOMAKE_FILES) HELP.html \
rtems_header.html.in rtems_footer.html.in
+EXTRA_DIST += common/cpright.texi common/setup.texi common/timemac.texi \
+ common/timetbl.t common/treedef.tex common/wksheets.t common/timing.t
+
+html_imagesdir = $(htmldir)/images
+
+HTML_IMAGES = images/dir-arrow.gif images/dvi.gif images/missing-arrow.gif images/next-arrow.gif \
+ images/oaronly.jpg images/pdf.gif images/pdf1.gif images/prev-arrow.gif images/ps.gif images/up-arrow.gif
+
+if USE_HTML
+html_images_DATA = $(HTML_IMAGES)
+endif
+
+EXTRA_DIST += $(HTML_IMAGES)