summaryrefslogtreecommitdiffstats
path: root/cpukit/telnetd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/telnetd/Makefile.am')
-rw-r--r--cpukit/telnetd/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/cpukit/telnetd/Makefile.am b/cpukit/telnetd/Makefile.am
new file mode 100644
index 0000000000..a2b581a700
--- /dev/null
+++ b/cpukit/telnetd/Makefile.am
@@ -0,0 +1,21 @@
+##
+## $Id$
+##
+
+include $(top_srcdir)/automake/compile.am
+
+if LIBNETWORKING
+if LIBSHELL
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = pty.h telnetd.h passwd.h
+
+project_lib_LIBRARIES = libtelnetd.a
+libtelnetd_a_SOURCES = check_passwd.c des.c icmds.c pty.c telnetd.c
+libtelnetd_a_CPPFLAGS = $(AM_CPPFLAGS)
+endif
+endif
+
+EXTRA_DIST = README
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/automake/local.am