summaryrefslogtreecommitdiffstats
path: root/cpukit/telnetd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cpukit/telnetd/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/cpukit/telnetd/Makefile.am b/cpukit/telnetd/Makefile.am
index d114ba4a3b..e2ae6a92ae 100644
--- a/cpukit/telnetd/Makefile.am
+++ b/cpukit/telnetd/Makefile.am
@@ -2,10 +2,12 @@ include $(top_srcdir)/automake/compile.am
if LIBNETWORKING
if LIBSHELL
-include_rtemsdir = $(includedir)/rtems
-include_rtems_HEADERS = pty.h telnetd.h passwd.h
-
project_lib_LIBRARIES = libtelnetd.a
+
+$(PROJECT_LIB)/libtelnetd.a: libtelnetd.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libtelnetd.a
+TMPINSTALL_FILES = $(PROJECT_LIB)/libtelnetd.a
+
libtelnetd_a_SOURCES = check_passwd.c des.c pty.c telnetd.c
libtelnetd_a_CPPFLAGS = $(AM_CPPFLAGS)
endif
@@ -13,5 +15,4 @@ endif
EXTRA_DIST = README
-include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am