summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/x86_64/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/x86_64/Makefile.am')
-rw-r--r--cpukit/score/cpu/x86_64/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/cpukit/score/cpu/x86_64/Makefile.am b/cpukit/score/cpu/x86_64/Makefile.am
new file mode 100644
index 0000000000..db4bd15cd5
--- /dev/null
+++ b/cpukit/score/cpu/x86_64/Makefile.am
@@ -0,0 +1,12 @@
+include $(top_srcdir)/automake/compile.am
+
+noinst_LIBRARIES = libscorecpu.a
+libscorecpu_a_SOURCES = cpu.c
+libscorecpu_a_SOURCES += ../no_cpu/cpucounterfrequency.c
+libscorecpu_a_SOURCES += ../no_cpu/cpucounterread.c
+libscorecpu_a_SOURCES += x86_64-context-initialize.c
+libscorecpu_a_SOURCES += x86_64-context-switch.S
+libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
+
+include $(top_srcdir)/automake/local.am
+include $(srcdir)/headers.am