summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/unix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/unix/Makefile.am')
-rw-r--r--cpukit/score/cpu/unix/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/cpukit/score/cpu/unix/Makefile.am b/cpukit/score/cpu/unix/Makefile.am
new file mode 100644
index 0000000000..d55b67a02c
--- /dev/null
+++ b/cpukit/score/cpu/unix/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+SUBDIRS = rtems
+
+AM_CPPFLAGS = -DCPU_SYNC_IO $(LIBC_DEFINES)
+
+# C source names, if any, go here -- minus the .c
+C_FILES = cpu.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+REL = $(ARCH)/rtems-cpu.rel
+
+$(REL): $(C_O_FILES)
+ $(make-rel)
+
+all-local: $(ARCH) $(REL) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = \
+cpu.c
+
+include $(top_srcdir)/../../../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../../../automake/local.am