summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/sh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/sh/Makefile.am')
-rw-r--r--cpukit/score/cpu/sh/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/cpukit/score/cpu/sh/Makefile.am b/cpukit/score/cpu/sh/Makefile.am
index 3fbdc75065..35ef6b429d 100644
--- a/cpukit/score/cpu/sh/Makefile.am
+++ b/cpukit/score/cpu/sh/Makefile.am
@@ -11,17 +11,11 @@ include_rtems_scoredir = $(includedir)/rtems/score
include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/types.h \
rtems/score/sh.h rtems/score/sh_io.h
-EXTRA_LIBRARIES = libscorecpu.a
-CLEANFILES = libscorecpu.a
+noinst_LIBRARIES = libscorecpu.a
libscorecpu_a_SOURCES = cpu.c
libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-EXTRA_LIBRARIES += libscorecpu_g.a
-CLEANFILES += libscorecpu_g.a
-libscorecpu_g_a_SOURCES = $(libscorecpu_a_SOURCES)
-libscorecpu_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-
-all-local: $(PREINSTALL_FILES) libscorecpu$(LIB_VARIANT).a
+all-local: $(PREINSTALL_FILES)
PREINSTALL_DIRS =
PREINSTALL_FILES =
@@ -56,7 +50,7 @@ $(PROJECT_INCLUDE)/rtems/score/sh_io.h: rtems/score/sh_io.h $(PROJECT_INCLUDE)/r
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/sh_io.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/sh_io.h
-CLEANFILES += $(PREINSTALL_FILES)
+CLEANFILES = $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/automake/local.am