summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/mips64orion/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/mips64orion/Makefile.am')
-rw-r--r--cpukit/score/cpu/mips64orion/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/cpukit/score/cpu/mips64orion/Makefile.am b/cpukit/score/cpu/mips64orion/Makefile.am
index 4f515d2147..5ed80f86ce 100644
--- a/cpukit/score/cpu/mips64orion/Makefile.am
+++ b/cpukit/score/cpu/mips64orion/Makefile.am
@@ -10,7 +10,7 @@ SUBDIRS = rtems
C_FILES = cpu.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-H_FILES = asm.h cpu_asm.h idtcpu.h idtmon.h iregdef.h
+include_HEADERS = asm.h cpu_asm.h idtcpu.h idtmon.h iregdef.h
S_FILES = cpu_asm.S
S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
@@ -35,7 +35,7 @@ rtems_cpu_rel_OBJECTS = $(C_O_FILES) $(S_O_FILES)
$(REL): $(rtems_cpu_rel_OBJECTS)
$(make-rel)
-PREINSTALL_FILES += $(PROJECT_INCLUDE) $(H_FILES:%=$(PROJECT_INCLUDE)/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o
@@ -44,8 +44,7 @@ all-local: $(ARCH) $(PREINSTALL_FILES) $(rtems_cpu_rel_OBJECTS) $(REL) \
.PRECIOUS: $(REL)
-EXTRA_DIST = asm.h cpu.c cpu_asm.S cpu_asm.h idtcpu.h idtmon.h iregdef.h \
- rtems.c
+EXTRA_DIST = cpu.c cpu_asm.S rtems.c
include $(top_srcdir)/../../../../../../automake/subdirs.am
include $(top_srcdir)/../../../../../../automake/local.am