summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/hppa1.1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/hppa1.1/Makefile.am')
-rw-r--r--cpukit/score/cpu/hppa1.1/Makefile.am62
1 files changed, 0 insertions, 62 deletions
diff --git a/cpukit/score/cpu/hppa1.1/Makefile.am b/cpukit/score/cpu/hppa1.1/Makefile.am
deleted file mode 100644
index 920e5501e0..0000000000
--- a/cpukit/score/cpu/hppa1.1/Makefile.am
+++ /dev/null
@@ -1,62 +0,0 @@
-##
-## $Id$
-##
-
-ACLOCAL_AMFLAGS = -I ../../../aclocal
-
-include $(top_srcdir)/../../../automake/multilib.am
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE):
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems/score:
- $(mkinstalldirs) $@
-
-include_HEADERS=
-PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = \
- rtems/score/cpu.h \
- rtems/score/cpu_asm.h \
- rtems/score/hppa.h \
- rtems/score/types.h \
- rtems/score/offsets.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
-
-C_FILES = cpu.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-S_FILES = cpu_asm.S
-OBJS += $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
-
-LIB = $(ARCH)/libscorecpu.a
-
-$(LIB): $(OBJS)
- $(make-library)
-
-all-local: $(ARCH) rtems/score/offsets.h $(PREINSTALL_FILES) $(LIB) \
- $(TMPINSTALL_FILES)
-
-EXTRA_DIST = cpu.c cpu_asm.S
-
-# FIXME: We should get rid of genoffsets
-GENOFFSETS = $(PROJECT_TOPdir)/tools/cpu/hppa1.1/genoffsets
-
-GENERIC_H_FILES = rtems/score/offsets.h
-rtems/score/offsets.h: $(GENOFFSETS) rtems/score/cpu.h
- $(mkinstalldirs) rtems/score
- $(RM) $@
- $(GENOFFSETS) > $@
-CLEANFILES = rtems/score/offsets.h
-
-include $(top_srcdir)/../../../automake/local.am