summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/sapi/include/Makefile.am')
-rw-r--r--cpukit/sapi/include/Makefile.am29
1 files changed, 21 insertions, 8 deletions
diff --git a/cpukit/sapi/include/Makefile.am b/cpukit/sapi/include/Makefile.am
index 7b3b7544f9..44b6440796 100644
--- a/cpukit/sapi/include/Makefile.am
+++ b/cpukit/sapi/include/Makefile.am
@@ -2,21 +2,34 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
+
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
include_HEADERS = confdefs.h
PREINSTALL_FILES = $(PROJECT_INCLUDE) \
$(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-$(PROJECT_INCLUDE):
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
+include_rtemsdir = $(includedir)/rtems
-all-local: $(PREINSTALL_FILES)
+include_rtems_HEADERS = rtems/config.h rtems/directives.h rtems/extension.h \
+ rtems/fatal.h rtems/init.h rtems/io.h rtems/mptables.h rtems/sptables.h
-SUBDIRS = rtems
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+EXTRA_DIST = rtems/README
+
+rtems/sptables.h: $(top_builddir)/config.status $(top_srcdir)/sapi/include/rtems/sptables.h.in
+ cd $(top_builddir) && CONFIG_FILES=sapi/include/$@ CONFIG_HEADERS= CONFIG_LINKS= $(SHELL) ./config.status
+
+all-local: $(PREINSTALL_FILES)
-include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am