summaryrefslogtreecommitdiffstats
path: root/cpukit/pppd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cpukit/pppd/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/cpukit/pppd/Makefile.am b/cpukit/pppd/Makefile.am
index 2cf38edc69..53a05761f4 100644
--- a/cpukit/pppd/Makefile.am
+++ b/cpukit/pppd/Makefile.am
@@ -1,10 +1,12 @@
include $(top_srcdir)/automake/compile.am
if LIBNETWORKING
-include_rtemsdir = $(includedir)/rtems
-include_rtems_HEADERS = rtemspppd.h rtemsdialer.h
-
project_lib_LIBRARIES = libpppd.a
+
+$(PROJECT_LIB)/libpppd.a: libpppd.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libpppd.a
+TMPINSTALL_FILES = $(PROJECT_LIB)/libpppd.a
+
libpppd_a_SOURCES = auth.c ccp.c ccp.h chap.c chap.h chap_ms.c chap_ms.h \
chat.c demand.c fsm.c fsm.h ipcp.c ipcp.h lcp.c lcp.h magic.c magic.h \
options.c upap.c upap.h utils.c sys-rtems.c \
@@ -13,5 +15,4 @@ libpppd_a_SOURCES = auth.c ccp.c ccp.h chap.c chap.h chap_ms.c chap_ms.h \
libpppd_a_CPPFLAGS = $(AM_CPPFLAGS) -D__BSD_VISIBLE -I$(srcdir)/../libmd
endif
-include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am