summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/posix/include/Makefile.am')
-rw-r--r--cpukit/posix/include/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/cpukit/posix/include/Makefile.am b/cpukit/posix/include/Makefile.am
index 01adb60973..4abe5df1ee 100644
--- a/cpukit/posix/include/Makefile.am
+++ b/cpukit/posix/include/Makefile.am
@@ -5,7 +5,8 @@
AUTOMAKE_OPTIONS = foreign 1.4
## RTEMS unistd.h needs to be checked against newlib's and removed
-#noinst_HEADERS= devctl.h intr.h
+UNUSED_H_FILES = devctl.h intr.h unistd.h
+
H_FILES = pthread.h sched.h aio.h mqueue.h semaphore.h
noinst_HEADERS = $(H_FILES)
@@ -25,7 +26,7 @@ profile-am: $(PREINSTALL_FILES)
SUBDIRS = rtems sys
-EXTRA_DIST = intr.h devctl.h
+EXTRA_DIST = $(UNUSED_H_FILES)
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am