summaryrefslogtreecommitdiffstats
path: root/cpukit/mghttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/mghttpd/Makefile.am')
-rw-r--r--cpukit/mghttpd/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/cpukit/mghttpd/Makefile.am b/cpukit/mghttpd/Makefile.am
new file mode 100644
index 0000000000..2c2a918029
--- /dev/null
+++ b/cpukit/mghttpd/Makefile.am
@@ -0,0 +1,16 @@
+include $(top_srcdir)/automake/compile.am
+
+if LIBNETWORKING
+include_mghttpddir = $(includedir)/mghttpd
+
+project_lib_LIBRARIES = libmghttpd.a
+libmghttpd_a_CPPFLAGS = $(AM_CPPFLAGS)
+# libmghttpd_a_CPPFLAGS += -DHAVE_MD5
+libmghttpd_a_CPPFLAGS += -DNO_SSI -DNO_SSL -DNO_CGI
+
+libmghttpd_a_SOURCES = mongoose.c mongoose.h
+include_mghttpd_HEADERS = mongoose.h
+endif
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/automake/local.am