summaryrefslogtreecommitdiffstats
path: root/cpukit/mghttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cpukit/mghttpd/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/cpukit/mghttpd/Makefile.am b/cpukit/mghttpd/Makefile.am
index bb5f84ba16..c3e605c679 100644
--- a/cpukit/mghttpd/Makefile.am
+++ b/cpukit/mghttpd/Makefile.am
@@ -2,17 +2,18 @@ include $(top_srcdir)/automake/compile.am
if LIBNETWORKING
if HAS_PTHREADS
-include_mghttpddir = $(includedir)/mghttpd
-
project_lib_LIBRARIES = libmghttpd.a
+
+$(PROJECT_LIB)/libmghttpd.a: libmghttpd.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libmghttpd.a
+TMPINSTALL_FILES = $(PROJECT_LIB)/libmghttpd.a
+
libmghttpd_a_CPPFLAGS = $(AM_CPPFLAGS)
# libmghttpd_a_CPPFLAGS += -DHAVE_MD5
libmghttpd_a_CPPFLAGS += -DNO_SSL -DNO_POPEN -DNO_CGI -DUSE_WEBSOCKET
libmghttpd_a_SOURCES = mongoose.c mongoose.h
-include_mghttpd_HEADERS = mongoose.h
endif
endif
-include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am