summaryrefslogtreecommitdiffstats
path: root/cpukit/librpc/include/rpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/librpc/include/rpc/Makefile.am')
-rw-r--r--cpukit/librpc/include/rpc/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/cpukit/librpc/include/rpc/Makefile.am b/cpukit/librpc/include/rpc/Makefile.am
index 5ca801b3c9..a917bd86dc 100644
--- a/cpukit/librpc/include/rpc/Makefile.am
+++ b/cpukit/librpc/include/rpc/Makefile.am
@@ -4,14 +4,15 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = auth.h rpc.h svc.h types.h clnt.h rpc_msg.h svc_auth.h xdr.h
+H_FILES = auth.h auth_des.h auth_unix.h clnt.h des.h des_crypt.h pmap_clnt.h \
+ pmap_prot.h pmap_rmt.h rpc.h rpc_com.h rpc_msg.h svc.h svc_auth.h \
+ types.h xdr.h
noinst_HEADERS = $(H_FILES)
if HAS_NETWORKING
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rpc \
-$(H_FILES:%=$(PROJECT_INCLUDE)/rpc/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rpc \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/rpc/%)
$(PROJECT_INCLUDE)/rpc:
@$(mkinstalldirs) $@
@@ -19,8 +20,6 @@ $(PROJECT_INCLUDE)/rpc/%.h: %.h
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am