summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/machine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libnetworking/machine/Makefile.am')
-rw-r--r--cpukit/libnetworking/machine/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/cpukit/libnetworking/machine/Makefile.am b/cpukit/libnetworking/machine/Makefile.am
index 11e23bf86c..e703d0b82b 100644
--- a/cpukit/libnetworking/machine/Makefile.am
+++ b/cpukit/libnetworking/machine/Makefile.am
@@ -1,10 +1,23 @@
-##
+##
## $Id$
-##
+##
AUTOMAKE_OPTIONS = foreign 1.4
-EXTRA_DIST = conf.h cpu.h cpufunc.h endian.h in_cksum.h limits.h param.h \
+H_FILES = conf.h cpu.h cpufunc.h endian.h in_cksum.h limits.h param.h \
types.h vmparam.h
+noinst_HEADERS = $(H_FILES)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/machine \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/machine/%)
+
+$(PROJECT_INCLUDE)/machine:
+ @$(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/machine/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
include $(top_srcdir)/../../../automake/local.am