summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index a2dca14fc8..2a470b5212 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -7,9 +7,11 @@ ACLOCAL_AMFLAGS = -I ../aclocal
SUBDIRS = arpa kern machine sys vm lib libc net netinet nfs rtems
SUBDIRS += wrapup
+## poll.h is not in the list because RTEMS does not have poll()
+## and installing poll.h confuses autoconf.
include_HEADERS = \
bpfilter.h loop.h netdb.h opt_ipfw.h opt_mrouting.h \
- opt_tcpdebug.h poll.h resolv.h syslog.h memory.h
+ opt_tcpdebug.h resolv.h syslog.h memory.h
PREINSTALL_FILES = $(PROJECT_INCLUDE) \
$(include_HEADERS:%=$(PROJECT_INCLUDE)/%)