summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/serdbg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cpukit/libmisc/serdbg/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/cpukit/libmisc/serdbg/Makefile.am b/cpukit/libmisc/serdbg/Makefile.am
deleted file mode 100644
index e09d24b8dc..0000000000
--- a/cpukit/libmisc/serdbg/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-##
-## $Id$
-##
-
-include_rtemsdir = $(includedir)/rtems
-
-LIBNAME = libserdbg
-LIB = $(ARCH)/$(LIBNAME).a
-
-C_FILES = serdbg.c serdbgio.c termios_printk.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-if LIBSERDBG
-include_HEADERS = serdbgcnf.h serdbg.h termios_printk_cnf.h \
- termios_printk.h
-endif
-
-include $(top_srcdir)/automake/compile.am
-include $(top_srcdir)/automake/lib.am
-
-AM_CPPFLAGS += -I$(top_builddir)
-
-$(PROJECT_INCLUDE):
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(LIB): $(OBJS)
- $(make-library)
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE) \
- $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-if LIBSERDBG
-all-local: $(ARCH) $(PREINSTALL_FILES) $(LIB)
-endif
-
-.PRECIOUS: $(LIB)
-
-EXTRA_DIST = README serdbg.c serdbgio.c serdbgcnf.h serdbg.h \
- termios_printk.c termios_printk.h termios_printk_cnf.h
-
-include $(top_srcdir)/automake/local.am