summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/fsmount/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libmisc/fsmount/Makefile.am')
-rw-r--r--cpukit/libmisc/fsmount/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/cpukit/libmisc/fsmount/Makefile.am b/cpukit/libmisc/fsmount/Makefile.am
new file mode 100644
index 0000000000..12b0f6976b
--- /dev/null
+++ b/cpukit/libmisc/fsmount/Makefile.am
@@ -0,0 +1,43 @@
+##
+## Makefile.am,v 1.9 2002/08/11 05:51:17 ralf Exp
+##
+
+
+include_rtemsdir = $(includedir)/rtems
+
+LIBNAME = libfsmount
+LIB = $(ARCH)/$(LIBNAME).a
+
+C_FILES = fsmount.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+
+include_rtems_HEADERS = fsmount.h
+
+OBJS = $(C_O_FILES)
+
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/lib.am
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = README fsmount.c
+
+include $(top_srcdir)/../automake/local.am
+