summaryrefslogtreecommitdiffstats
path: root/cpukit/libfs/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libfs/wrapup/Makefile.am')
-rw-r--r--cpukit/libfs/wrapup/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/cpukit/libfs/wrapup/Makefile.am b/cpukit/libfs/wrapup/Makefile.am
new file mode 100644
index 0000000000..5787d8056f
--- /dev/null
+++ b/cpukit/libfs/wrapup/Makefile.am
@@ -0,0 +1,41 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = libfs
+LIB = $(ARCH)/$(LIBNAME).a
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+#if HAS_IMFS
+IMFSLIB = ../src/imfs/$(ARCH)/libimfs.a
+#endif
+
+TMP_LIBS = $(IMFSLIB)
+
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): $(TMP_LIBS)
+ $(RM) $@
+ $(RM) -r $(ARCH)
+ mkdir $(ARCH)
+ cd $(ARCH); for lib in $^; do $(AR) -xv ../$$lib; done
+ $(AR) ruv $@ $(ARCH)/*
+ $(RANLIB) $@
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+
+all-local: $(ARCH) $(LIB) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(LIB)
+
+include $(top_srcdir)/../../../automake/local.am