summaryrefslogtreecommitdiffstats
path: root/cpukit/libblock/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libblock/Makefile.am')
-rw-r--r--cpukit/libblock/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/cpukit/libblock/Makefile.am b/cpukit/libblock/Makefile.am
new file mode 100644
index 0000000000..6a047b5059
--- /dev/null
+++ b/cpukit/libblock/Makefile.am
@@ -0,0 +1,17 @@
+##
+## $Id$
+##
+
+include $(top_srcdir)/automake/multilib.am
+include $(top_srcdir)/automake/compile.am
+
+if !UNIX
+noinst_LIBRARIES = libblock.a
+libblock_a_SOURCES = src/bdbuf.c src/blkdev.c src/diskdevs.c src/ramdisk.c \
+ src/ide_part_table.c include/rtems/bdbuf.h include/rtems/blkdev.h \
+ include/rtems/diskdevs.h include/rtems/ramdisk.h \
+ include/rtems/ide_part_table.h
+endif
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/automake/local.am