summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/macros/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/itron/macros/Makefile.am')
-rw-r--r--cpukit/itron/macros/Makefile.am23
1 files changed, 20 insertions, 3 deletions
diff --git a/cpukit/itron/macros/Makefile.am b/cpukit/itron/macros/Makefile.am
index 32269fcdcd..9ac3af11c1 100644
--- a/cpukit/itron/macros/Makefile.am
+++ b/cpukit/itron/macros/Makefile.am
@@ -2,9 +2,26 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
-SUBDIRS = rtems
+include_rtems_itrondir = $(includedir)/rtems/itron
+
+$(PROJECT_INCLUDE)/rtems/itron:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%: %
+ $(INSTALL_DATA) $< $@
+
+if MACROS
+include_rtems_itron_HEADERS = rtems/itron/eventflags.inl \
+ rtems/itron/fmempool.inl rtems/itron/intr.inl rtems/itron/mbox.inl \
+ rtems/itron/msgbuffer.inl rtems/itron/network.inl rtems/itron/port.inl \
+ rtems/itron/semaphore.inl rtems/itron/sysmgmt.inl rtems/itron/task.inl \
+ rtems/itron/time.inl rtems/itron/vmempool.inl
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/itron \
+ $(include_rtems_itron_HEADERS:%=$(PROJECT_INCLUDE)/%)
+endif
+
+all-local: $(PREINSTALL_FILES)
-include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am