summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cpukit/itron/configure.ac63
1 files changed, 63 insertions, 0 deletions
diff --git a/cpukit/itron/configure.ac b/cpukit/itron/configure.ac
new file mode 100644
index 0000000000..9d28b050b1
--- /dev/null
+++ b/cpukit/itron/configure.ac
@@ -0,0 +1,63 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([include/itronsys])
+RTEMS_TOP(../../../..)
+AC_CONFIG_AUX_DIR(../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-exec-itron,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_ITRON
+RTEMS_ENABLE_INLINES
+
+RTEMS_ENV_RTEMSCPU
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_ITRON_API(RTEMS_BSP)
+
+# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
+if test "$RTEMS_USE_MACROS" = "yes"; then
+ INLINEdir="macros"
+else
+ INLINEdir="inline"
+fi
+AM_CONDITIONAL(INLINE,test "$INLINEdir" = "inline" )
+AM_CONDITIONAL(MACROS,test "$INLINEdir" = "macros" )
+
+## Needed when using automake for libs/rels
+RTEMS_CHECK_NEWLIB
+
+AM_CONFIG_HEADER(src/config.h)
+
+##
+## FIXME: We configure and build the macros subdirectory, too.
+## Should probably use AM_CONDITIONALs to disable them in future
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+src/Makefile
+include/Makefile
+include/itronsys/Makefile
+include/rtems/Makefile
+include/rtems/itron/Makefile
+inline/Makefile
+inline/rtems/Makefile
+inline/rtems/itron/Makefile
+macros/Makefile
+macros/rtems/Makefile
+macros/rtems/itron/Makefile
+])
+AC_OUTPUT
+