summaryrefslogtreecommitdiffstats
path: root/cpukit/ftpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/ftpd/Makefile.am')
-rw-r--r--cpukit/ftpd/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/cpukit/ftpd/Makefile.am b/cpukit/ftpd/Makefile.am
index bbba6e064c..a4f4e019f8 100644
--- a/cpukit/ftpd/Makefile.am
+++ b/cpukit/ftpd/Makefile.am
@@ -34,9 +34,17 @@ EXTRA_DIST = ftpd.c ftpd.h
include_HEADERS = ftpd.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+include_rtems_HEADERS = telnetd.h
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE) \
+ $(include_HEADERS:%=$(PROJECT_INCLUDE)/%) \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
+ $(INSTALL_DATA) $< $@
include $(top_srcdir)/../../../automake/local.am