summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac20
1 files changed, 6 insertions, 14 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index a19b0c9637..a1cc748264 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -93,8 +93,12 @@ RTEMS_CHECK_FUNC([pthread_attr_getstack],[#include <pthread.h>])
AC_CHECK_FUNCS([ttyname getcwd])
# </FIXME>
-## Check if the installed toolchain has these headers
-AC_CHECK_HEADERS([tar.h errno.h sched.h])
+# Check if the installed toolchain provides these headers
+# and error out if not.
+AC_CHECK_HEADERS([tar.h errno.h sched.h sys/cdefs.h sys/queue.h],,
+ [rtems_missing_header="$ac_header";break])
+AS_IF([test -n "$rtems_missing_header"],
+ AC_MSG_ERROR([Missing required header $rtems_missing_header])])
## error out if libc doesn't provide stdint.h
AS_IF([test x"${ac_cv_header_stdint_h}" != xyes],
@@ -104,18 +108,6 @@ AS_IF([test x"${ac_cv_header_stdint_h}" != xyes],
AS_IF([test x"${ac_cv_header_inttypes_h}" != xyes],
[AC_MSG_ERROR([Required header inttypes.h not found])])
-## error out if libc doesn't provide errno.h
-AS_IF([test x"${ac_cv_header_errno_h}" != xyes],
-[AC_MSG_ERROR([Required header errno.h not found])])
-
-## error out if libc doesn't provide sched.h
-AS_IF([test x"${ac_cv_header_sched_h}" != xyes],
-[AC_MSG_ERROR([Required header sched.h not found])])
-
-## error out if libc doesn't provide tar.h
-AS_IF([test x"${ac_cv_header_tar_h}" != xyes],
-[AC_MSG_ERROR([Required header tar.h not found])])
-
AC_HEADER_STDBOOL
AS_IF([test x"${ac_cv_header_stdbool_h}" != xyes],
[AC_MSG_ERROR([No sufficient stdbool.h found])])