summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cpukit/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index a8833f6e6b..431d4dc81f 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1217,7 +1217,6 @@ _SUBDIRS += wrapup
# other libraries
_SUBDIRS += zlib
-_SUBDIRS += telnetd
project_lib_LIBRARIES += libftpd.a
@@ -1229,6 +1228,19 @@ libftpd_a_SOURCES =
libftpd_a_SOURCES += ftpd/ftpd.c
libftpd_a_SOURCES += ftpd/ftpd-init.c
+project_lib_LIBRARIES += libtelnetd.a
+
+$(PROJECT_LIB)/libtelnetd.a: libtelnetd.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libtelnetd.a
+TMPINSTALL_FILES += $(PROJECT_LIB)/libtelnetd.a
+
+libtelnetd_a_SOURCES =
+libtelnetd_a_SOURCES += telnetd/check_passwd.c
+libtelnetd_a_SOURCES += telnetd/des.c
+libtelnetd_a_SOURCES += telnetd/pty.c
+libtelnetd_a_SOURCES += telnetd/telnetd.c
+libtelnetd_a_SOURCES += telnetd/telnetd-init.c
+
if LIBDEBUGGER
project_lib_LIBRARIES += libdebugger.a