summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5ba77d2f8f..5ba2e06d2e 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,3 @@
-
dnl Process this file with autoconf to produce a configure script.
dnl
dnl $Id$
@@ -7,6 +6,14 @@ AC_PREREQ(2.13)
AC_INIT(c)
RTEMS_TOP(.)
+# Abort if trying to build inside of the source tree.
+if test -f VERSION; then
+ rm -f config.cache config.log confdefs.h
+ AC_MSG_ERROR([***]
+ [Attempt to build inside of the source tree]
+ [Please use a separate build directory, instead] )
+fi
+
RTEMS_CANONICAL_TARGET_CPU
AM_INIT_AUTOMAKE(rtems,$RTEMS_VERSION,no)
AM_MAINTAINER_MODE
@@ -26,7 +33,6 @@ RTEMS_ENABLE_CXX
RTEMS_ENABLE_GCC28
RTEMS_ENABLE_LIBCDIR
RTEMS_ENABLE_TESTS
-RTEMS_ENABLE_HWAPI
RTEMS_CHECK_CPU
RTEMS_CANONICAL_HOST
@@ -41,7 +47,7 @@ RTEMS_CONFIG_SUBDIRS(c)
if test "$target_alias" != "$host_alias"; then
changequote(,)dnl
TARGET_SUBDIRS=`echo "$target_subdirs" | \
- sed -e "s%\([^ ]\+\)%$target_alias/\1%g"`
+ sed -e "s%\([a-zA-Z0-9][a-zA-Z0-9]*\)%${target_alias}/\1%g"`
changequote([,])dnl
else
TARGET_SUBDIRS="$target_subdirs"