summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f903cd7b94..a4a9125b38 100644
--- a/configure.in
+++ b/configure.in
@@ -318,8 +318,18 @@ if test -d "$srcdir/c/src/lib/libbsp/$target_cpu"; then
# Is there code where there should be for this BSP?
# The bare bsp is a special case as it is not under the target_cpu path
case $i in
- bare) bspcpudir= ;;
- *) bspcpudir=$target_cpu/ ;;
+ bare)
+ bspcpudir=
+ if test "X${BARE_CPU_CFLAGS}" = "X" ; then
+ AC_MSG_ERROR([--enable-bare-cpu-flags not specified for bare bsp])
+ fi
+ if test "X${BARE_CPU_MODEL}" = "X" ; then
+ AC_MSG_ERROR([--enable-bare-cpu-model not specified for bare bsp])
+ fi
+ ;;
+ *)
+ bspcpudir=$target_cpu/
+ ;;
esac
if test -d "$srcdir/c/src/lib/libbsp/$bspcpudir$bspdir"; then