summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2d1842e2d7..d1fb7f23da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,12 +25,16 @@ RTEMS_ENABLE_MULTIPROCESSING
RTEMS_ENABLE_POSIX
RTEMS_ENABLE_NETWORKING
RTEMS_ENABLE_CXX
-RTEMS_ENABLE_TESTS
+RTEMS_ENABLE_TESTS
RTEMS_ENABLE_RTEMS_DEBUG
RTEMS_ENABLE_RTEMSBSP
RTEMS_ENABLE_PARAVIRT
RTEMS_ENABLE_DRVMGR
+## Check if there are valid tools install and in the path.
+RTEMS_CHECK_TOOL(RTEMS_CC,gcc)
+test -z "$RTEMS_CC" && AC_MSG_ERROR([no acceptable cc found in \$PATH])
+
## NOTES:
## * tools/build are host-native tools to be installed on the host.
## * tools/cpu are host-native or host-cross-target-tools