summaryrefslogtreecommitdiffstats
path: root/c/src/tests/support/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/tests/support/include/Makefile.am')
-rw-r--r--c/src/tests/support/include/Makefile.am18
1 files changed, 6 insertions, 12 deletions
diff --git a/c/src/tests/support/include/Makefile.am b/c/src/tests/support/include/Makefile.am
index 72f0f3c837..d5d258b558 100644
--- a/c/src/tests/support/include/Makefile.am
+++ b/c/src/tests/support/include/Makefile.am
@@ -4,26 +4,20 @@
AUTOMAKE_OPTIONS = foreign 1.4
-project_bspdir=$(PROJECT_ROOT)/@RTEMS_BSP@
+project_bspdir = $(PROJECT_ROOT)/@RTEMS_BSP@
noinst_HEADERS = tmacros.h
-TMPINSTALLDIRS=$(project_bspdir)/lib/include
+TMPINSTALLFILES = $(project_bspdir)/lib/include \
+ $(project_bspdir)/lib/include/tmacros.h
-$(TMPINSTALLDIRS):
+$(project_bspdir)/lib/include:
$(mkinstalldirs) $@
-
-TMPINSTALLFILES = $(project_bspdir)/lib/include/tmacros.h
-
$(project_bspdir)/lib/include/tmacros.h: tmacros.h
$(INSTALL_DATA) $< $@
-CLEANFILES = $(TMPINSTALLFILES)
-
-install-tmp: $(TMPINSTALLFILES)
+CLEANFILES = $(project_bspdir)/lib/include/tmacros.h
-all: install-tmp
-debug: install-tmp
-profile: install-tmp
+all-local: $(TMPINSTALLFILES)
include $(top_srcdir)/../../../../automake/local.am