summaryrefslogtreecommitdiffstats
path: root/c/src/tests/support/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/tests/support/Makefile.am')
-rw-r--r--c/src/tests/support/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/c/src/tests/support/Makefile.am b/c/src/tests/support/Makefile.am
index bb79a6c15c..0cd6acdc57 100644
--- a/c/src/tests/support/Makefile.am
+++ b/c/src/tests/support/Makefile.am
@@ -4,7 +4,22 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
-SUBDIRS = include
+project_bspdir = $(PROJECT_ROOT)/@RTEMS_BSP@
+
+noinst_HEADERS = include/tmacros.h include/buffer_test_io.h
+
+TMPINSTALLFILES = $(project_bspdir)/lib/include \
+ $(project_bspdir)/lib/include/tmacros.h \
+ $(project_bspdir)/lib/include/buffer_test_io.h
+
+$(project_bspdir)/lib/include:
+ $(mkinstalldirs) $@
+$(project_bspdir)/lib/include/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+CLEANFILES = $(project_bspdir)/lib/include/tmacros.h \
+ $(project_bspdir)/lib/include/buffer_test_io.h
+
+all-local: $(TMPINSTALLFILES)
-include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am