summaryrefslogtreecommitdiffstats
path: root/c/src/tests/itrontests/itronhello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/tests/itrontests/itronhello/Makefile.am')
-rw-r--r--c/src/tests/itrontests/itronhello/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/c/src/tests/itrontests/itronhello/Makefile.am b/c/src/tests/itrontests/itronhello/Makefile.am
new file mode 100644
index 0000000000..a7f3bf2a1a
--- /dev/null
+++ b/c/src/tests/itrontests/itronhello/Makefile.am
@@ -0,0 +1,43 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+TEST = itronhello
+PGM = ${ARCH}/$(TEST).exe
+
+MANAGERS = all
+
+# C source names, if any, go here -- minus the .c
+C_FILES = init.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+H_FILES = system.h
+noinst_HEADERS =$(H_FILES)
+
+DOCTYPES = doc scn
+DOCS = $(DOCTYPES:%=$(TEST).%)
+
+SRCS = $(DOCS) $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+PGM = ${ARCH}/$(TEST).exe
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(RTEMS_ROOT)/make/leaf.cfg
+include $(top_srcdir)/itrontests.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+
+all-local: $(ARCH) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = $(C_FILES) $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am