summaryrefslogtreecommitdiffstats
path: root/c/src/support/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/support/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/c/src/support/Makefile.am b/c/src/support/Makefile.am
new file mode 100644
index 0000000000..9c528fc254
--- /dev/null
+++ b/c/src/support/Makefile.am
@@ -0,0 +1,20 @@
+##
+## $Id$
+##
+
+include $(top_srcdir)/../../automake/compile.am
+include $(top_srcdir)/../../automake/lib.am
+
+AM_CPPFLAGS += -DRTEMS_BSP=\"$(RTEMS_BSP)\"
+
+C_FILES=version.c
+OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+
+LIB = $(ARCH)/libsupport.a
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(ARCH) $(LIB)
+
+include $(top_srcdir)/../../automake/local.am