summaryrefslogtreecommitdiffstats
path: root/c/src/optman/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/optman/configure.ac')
-rw-r--r--c/src/optman/configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/c/src/optman/configure.ac b/c/src/optman/configure.ac
new file mode 100644
index 0000000000..e26e2807ab
--- /dev/null
+++ b/c/src/optman/configure.ac
@@ -0,0 +1,42 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([rtems])
+RTEMS_TOP(../../..)
+AC_CONFIG_AUX_DIR(../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-optman,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_MULTILIB
+RTEMS_ENABLE_MULTIPROCESSING
+RTEMS_ENABLE_POSIX
+RTEMS_ENABLE_ITRON
+RTEMS_ENABLE_INLINES
+RTEMS_ENABLE_GCC28
+RTEMS_ENABLE_RTEMS_DEBUG
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_RTEMS_DEBUG
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_NEWLIB
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+rtems/Makefile
+sapi/Makefile
+])
+AC_OUTPUT