summaryrefslogtreecommitdiffstats
path: root/c/src/make/custom/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/make/custom/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/c/src/make/custom/Makefile.am b/c/src/make/custom/Makefile.am
new file mode 100644
index 0000000000..3313913c03
--- /dev/null
+++ b/c/src/make/custom/Makefile.am
@@ -0,0 +1,19 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+rtems_makedir=$(prefix)/make
+rtems_make_customdir=$(rtems_makedir)/custom
+rtems_make_custom_DATA = @CUSTOM_CFG_FILES@
+
+noinst_DATA = \
+default.cfg
+
+if MAINTAINER_MODE
+$(srcdir)/default.cfg.in: $(top_srcdir)/@RTEMS_TOPdir@/make/custom/default.cfg
+ sed -e 's%\$$(RTEMS_BSP)%\@RTEMS_BSP\@%g' < $< >$@
+endif
+
+include $(top_srcdir)/../../../automake/local.am