summaryrefslogtreecommitdiffstats
path: root/c/src/librtems++/include/rtems++/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/librtems++/include/rtems++/Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/c/src/librtems++/include/rtems++/Makefile.am b/c/src/librtems++/include/rtems++/Makefile.am
index 67ace61e70..e7f2f0a836 100644
--- a/c/src/librtems++/include/rtems++/Makefile.am
+++ b/c/src/librtems++/include/rtems++/Makefile.am
@@ -5,14 +5,13 @@
AUTOMAKE_OPTIONS = foreign 1.4
if HAS_CXX
-H_FILES = rtemsEvent.h rtemsInterrupt.h rtemsMessageQueue.h \
- rtemsSemaphore.h rtemsStatusCode.h rtemsTask.h rtemsTaskMode.h rtemsTimer.h
+H_FILES = rtemsEvent.h rtemsInterrupt.h rtemsMessageQueue.h rtemsSemaphore.h \
+ rtemsStatusCode.h rtemsTask.h rtemsTaskMode.h rtemsTimer.h
noinst_HEADERS = $(H_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems++ \
-$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems++/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems++ \
+ $(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems++/%)
$(PROJECT_INCLUDE)/rtems++:
@$(mkinstalldirs) $@
@@ -20,8 +19,6 @@ $(PROJECT_INCLUDE)/rtems++/%.h: %.h
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am