summaryrefslogtreecommitdiffstats
path: root/c/src/librdbg/include/rdbg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/librdbg/include/rdbg/Makefile.am')
-rw-r--r--c/src/librdbg/include/rdbg/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/c/src/librdbg/include/rdbg/Makefile.am b/c/src/librdbg/include/rdbg/Makefile.am
index e9df695293..da76688469 100644
--- a/c/src/librdbg/include/rdbg/Makefile.am
+++ b/c/src/librdbg/include/rdbg/Makefile.am
@@ -15,13 +15,14 @@ SUBDIRS = $(RTEMS_CPU)
DIST_SUBDIRS = $(RTEMS_CPU)
endif
+PREINSTALL_DIRS =
PREINSTALL_FILES =
if HAS_RDBG
$(PROJECT_INCLUDE)/rdbg/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rdbg
@: > $(PROJECT_INCLUDE)/rdbg/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rdbg/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rdbg/$(dirstamp)
$(PROJECT_INCLUDE)/rdbg/rdbg.h: rdbg.h $(PROJECT_INCLUDE)/rdbg/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rdbg/rdbg.h
@@ -33,6 +34,7 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rdbg/servrpc.h
endif
CLEANFILES = $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/automake/subdirs.am
include $(top_srcdir)/automake/local.am