summaryrefslogtreecommitdiffstats
path: root/c/src/libnetworking/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/libnetworking/wrapup/Makefile.am')
-rw-r--r--c/src/libnetworking/wrapup/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/c/src/libnetworking/wrapup/Makefile.am b/c/src/libnetworking/wrapup/Makefile.am
index 712033e552..3b839ba14f 100644
--- a/c/src/libnetworking/wrapup/Makefile.am
+++ b/c/src/libnetworking/wrapup/Makefile.am
@@ -12,16 +12,18 @@ NET_O_PIECES = rtems_servers \
OBJS = $(foreach piece, $(NET_O_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT))
LIB = $(ARCH)/libnetapps.a
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
+include $(top_srcdir)/../../automake/compile.am
+include $(top_srcdir)/../../automake/lib.am
#
# (OPTIONAL) Add local stuff here using +=
#
+if HAS_NETWORKING
$(LIB): $(OBJS)
$(make-library)
all-local: $(ARCH) $(OBJS) $(LIB)
+endif
-include $(top_srcdir)/../../../automake/local.am
+include $(top_srcdir)/../../automake/local.am