summaryrefslogtreecommitdiffstats
path: root/c/src/libnetworking/sys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/libnetworking/sys/Makefile.am')
-rw-r--r--c/src/libnetworking/sys/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/c/src/libnetworking/sys/Makefile.am b/c/src/libnetworking/sys/Makefile.am
index b7fc58125d..abedf78d9c 100644
--- a/c/src/libnetworking/sys/Makefile.am
+++ b/c/src/libnetworking/sys/Makefile.am
@@ -4,16 +4,18 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = buf.h callout.h conf.h domain.h filio.h ioctl.h kernel.h libkern.h \
+
+
+include_sysdir = $(includedir)/sys
+
+include_sys_HEADERS = buf.h callout.h conf.h domain.h filio.h ioctl.h kernel.h libkern.h \
malloc.h mbuf.h mount.h param.h proc.h protosw.h queue.h reboot.h \
resourcevar.h rtprio.h select.h signalvar.h socket.h socketvar.h \
sockio.h sysctl.h syslimits.h syslog.h systm.h ttydefaults.h ucred.h \
uio.h un.h
-noinst_HEADERS = $(H_FILES)
-
PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \
- $(H_FILES:%=$(PROJECT_INCLUDE)/sys/%)
+ $(include_sys_HEADERS:%=$(PROJECT_INCLUDE)/sys/%)
$(PROJECT_INCLUDE)/sys:
@$(mkinstalldirs) $@