summaryrefslogtreecommitdiffstats
path: root/c/src/libmisc/untar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/libmisc/untar/Makefile.am')
-rw-r--r--c/src/libmisc/untar/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/c/src/libmisc/untar/Makefile.am b/c/src/libmisc/untar/Makefile.am
new file mode 100644
index 0000000000..2219fec095
--- /dev/null
+++ b/c/src/libmisc/untar/Makefile.am
@@ -0,0 +1,42 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = libuntar-tmp
+LIB = ${ARCH}/${LIBNAME}.a
+
+C_FILES = untar.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+H_FILES = untar.h
+noinst_HEADERS = $(H_FILES)
+
+SRCS = $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(RTEMS_ROOT)/make/lib.cfg
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems \
+$(H_FILES:%=$(PROJECT_INCLUDE)/rtems/%)
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+${LIB}: ${SRCS} ${OBJS}
+ $(make-library)
+
+all: ${ARCH} $(PREINSTALL_FILES) $(LIB) $(TMPINSTALL_FILES)
+
+EXTRA_DIST += $(C_FILES)
+
+include $(top_srcdir)/../../../automake/local.am