summaryrefslogtreecommitdiffstats
path: root/c/src/libfs/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/libfs/wrapup/Makefile.am')
-rw-r--r--c/src/libfs/wrapup/Makefile.am42
1 files changed, 0 insertions, 42 deletions
diff --git a/c/src/libfs/wrapup/Makefile.am b/c/src/libfs/wrapup/Makefile.am
deleted file mode 100644
index 0ce22c6cb8..0000000000
--- a/c/src/libfs/wrapup/Makefile.am
+++ /dev/null
@@ -1,42 +0,0 @@
-##
-## $Id$
-##
-
-
-LIBNAME = libfs
-LIB = $(ARCH)/$(LIBNAME).a
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
-IMFSLIB = ../src/imfs/$(ARCH)/libimfs.a
-
-if !UNIX
-DOSFSLIB = ../src/dosfs/$(ARCH)/libdosfs.a
-endif
-
-TMP_LIBS = $(IMFSLIB) $(DOSFSLIB)
-
-$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
- $(INSTALL_DATA) $< $@
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(LIB): $(TMP_LIBS)
- $(RM) $@
- $(RM) -r $(ARCH)
- mkdir $(ARCH)
- cd $(ARCH); for lib in $^; do $(AR) -xv ../$$lib; done
- $(AR) ruv $@ $(ARCH)/*
- $(RANLIB) $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
-
-all-local: $(ARCH) $(LIB) $(TMPINSTALL_FILES)
-
-.PRECIOUS: $(LIB)
-
-include $(top_srcdir)/../../../automake/local.am