summaryrefslogtreecommitdiffstats
path: root/c/src/libchip/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/libchip/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/libchip/configure.ac b/c/src/libchip/configure.ac
index 7a5f5e7580..09f869a03f 100644
--- a/c/src/libchip/configure.ac
+++ b/c/src/libchip/configure.ac
@@ -34,6 +34,11 @@ if test "$RTEMS_CPU" = "unix"; then
AC_MSG_ERROR(Can't build libchip for $RTEMS_CPU)
fi
+AS_IF([test "$host_cpu" = "sparc"],[
+ AC_DEFINE_UNQUOTED([CPU_U32_FIX],[1],
+ [whether to enable ipalignment work-around])
+])
+
AM_CONDITIONAL(HAS_NETWORKING, test "$HAS_NETWORKING" = "yes")
# Explicitly list all Makefiles here