summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7750/sci/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/sci/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am b/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am
new file mode 100644
index 0000000000..e37a7e7984
--- /dev/null
+++ b/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/sci.rel
+
+C_FILES = console.c sh4uart.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(top_srcdir)/../../../../../../make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+include $(top_srcdir)/../../../../../../automake/local.am