summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7045/include/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/c/src/lib/libcpu/sh/sh7045/include/Makefile.am b/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
index 8a424d634f..4a311c6547 100644
--- a/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
@@ -5,6 +5,7 @@
AUTOMAKE_OPTIONS = foreign 1.4
H_FILES = io_types.h null.h sci.h sh7_pfc.h sh7_sci.h
+SCORE_H_FILES = ispsh7045.h iosh7045.h
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
@@ -15,11 +16,15 @@ $(PROJECT_INCLUDE)/sh:
$(PROJECT_INCLUDE)/sh/%.h: %.h
$(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
TMPINSTALL_FILES += $(PROJECT_INCLUDE)/sh \
- $(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
+ $(H_FILES:%.h=$(PROJECT_INCLUDE)/sh/%.h) \
+ $(SCORE_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
all-local: $(TMPINSTALL_FILES)
EXTRA_DIST = io_types.h null.h sci.h sh7_pfc.h sh7_sci.h
-include $(top_srcdir)/../../../../../automake/local.am
+include $(top_srcdir)/../../../../../../automake/local.am