summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7045/include/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/c/src/lib/libcpu/sh/sh7045/include/Makefile.am b/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
index 10a2f74720..7fb244b465 100644
--- a/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
@@ -9,16 +9,17 @@ H_FILES = io_types.h null.h sci.h sh7_pfc.h sh7_sci.h
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
-TMPINSTALL_FILES = \
-$(PROJECT_INCLUDE)/sh \
-$(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
-
$(PROJECT_INCLUDE)/sh:
$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/sh/%.h: %.h
$(INSTALL_DATA) $< $@
+TMPINSTALL_FILES += $(PROJECT_INCLUDE)/sh \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
+
all-local: $(TMPINSTALL_FILES)
+EXTRA_DIST = io_types.h null.h sci.h sh7_pfc.h sh7_sci.h
+
include $(top_srcdir)/../../../../../automake/local.am