summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7045/include/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/sh7045/include/Makefile.am b/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
new file mode 100644
index 0000000000..10a2f74720
--- /dev/null
+++ b/c/src/lib/libcpu/sh/sh7045/include/Makefile.am
@@ -0,0 +1,24 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = io_types.h null.h sci.h sh7_pfc.h sh7_sci.h
+
+# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
+# file name conflicts
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/sh \
+$(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
+
+$(PROJECT_INCLUDE)/sh:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/sh/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am