summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7032/include/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7032/include/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/c/src/lib/libcpu/sh/sh7032/include/Makefile.am b/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
index feb0333fda..72e931ea32 100644
--- a/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
@@ -5,20 +5,21 @@
AUTOMAKE_OPTIONS = foreign 1.4
H_FILES = null.h sci.h sh7_pfc.h sh7_sci.h
-noinst_HEADERS = $(H_FILES)
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
-TMPINSTALL_FILES = $(PROJECT_INCLUDE)/sh \
- $(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
-
$(PROJECT_INCLUDE)/sh:
$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/sh/%.h: %.h
$(INSTALL_DATA) $< $@
+TMPINSTALL_FILES += $(PROJECT_INCLUDE)/sh \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
+
all-local: $(TMPINSTALL_FILES)
+EXTRA_DIST = null.h sci.h sh7_pfc.h sh7_sci.h
+
include $(top_srcdir)/../../../../../automake/local.am