summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7032/delay/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7032/delay/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/sh7032/delay/Makefile.am b/c/src/lib/libcpu/sh/sh7032/delay/Makefile.am
new file mode 100644
index 0000000000..9286cf8249
--- /dev/null
+++ b/c/src/lib/libcpu/sh/sh7032/delay/Makefile.am
@@ -0,0 +1,35 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/delay.rel
+
+## C source names
+C_FILES = delay.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+H_FILES =
+
+## Assembly source names
+S_FILES =
+S_O_FILES = $(S_FILES:%.S=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(RTEMS_ROOT)/make/leaf.cfg
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+${PGM}: ${OBJS}
+ $(make-rel)
+
+all: ${ARCH} $(PGM)
+
+EXTRA_DIST = $(C_FILES) $(S_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am