summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc8xx/timer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc8xx/timer/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc8xx/timer/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc8xx/timer/Makefile.am b/c/src/lib/libcpu/powerpc/mpc8xx/timer/Makefile.am
new file mode 100644
index 0000000000..39f0c9f3b6
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/mpc8xx/timer/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/timer.rel
+
+## C sources
+C_FILES = timer.c
+
+timer_rel_OBJECTS = $(C_FILES:%.c=${ARCH}/%.o)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CFLAGS = $(CFLAGS_OS_V)
+
+$(PGM): $(timer_rel_OBJECTS)
+ $(make-rel)
+
+all-local: ${ARCH} $(PGM)
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am